SSL-Verbindung fehlt Schloss

Korrekter Website in SSL-Verbindung ist das Schloss in der Adresszeile dabei. Die Farbe vom Schloss hängt allerdings vom Browser ab. Opera und Firefox haben bei einer erfolgreichen verschlüsselten Verbindung das grüne Schloss. Das ist unabhängig vom Zertifikat (also auch bei Let’s Encrypt hast du da ein cooles grünes Schloss). Bei Chrome grau und Safari iPad schwarz und am Mac grau (außer die erweiterten Zertifikate wie True Business EV). Hiermit zum eigentlichen Thema:

Der SSL-Verbindung fehlt das Schloss in der Adresszeile anhand eines Beispiels

Sofern über Dashboard das SSL-Schloss der Adresszeile durchgehend aufscheint und dabei den Webseiten teils das Schloss fehlt. Also bedingt im Verbindungsaufbau der Webseiten ist das Schlösschen evtl. kurz sichtbar und End-Verbindung verschwunden. Es sieht so aus, wie wenn diesen Webseiten die SSL-Verbindung* nicht anerkannt würde.

„Sicher“ sind solche Webseiten ohne Schloss an für sich schon, da das Zertifikat am Web-Host-Server auch korrekt angezeigt ist.

Wo könnte der Fehler sein? Die Antwort lautet: „Diesen Webseiten ist HTTP-Content eingebunden, somit ist das Schlösschen nicht sichtbar.“

Hier im Beispiel sind fast alle Webseiten (page) in SSL-Funktion mit Schloss. Demgegenüber sind der Startseite und dem Impressum sowie die gesamten Beiträge (post) das Schloss der SLL-Verbindung abgewiesen. Indes nach obigen Hinweis ist der zu entfernende HTTP-Content zu finden.

Es können sich im Content Links zu anderen Webseiten befinden, welche zur Setzung der ‚Links‘ nicht auf SSL umgestellt waren. Ebenda der Homeseite ein HTML-Widget mit Script zu einer Website (bspw. Wetterbericht). Und ist dabei im Impressum eine Verlinkung zur Homeseite, somit erfolgt auch das Impressum ohne Schloss in der Adresszeile.

  • Den ‚Links‘ durch Hinzufügen des szu http://also https:// ist hiermit leicht geholfen – sofern diese Websites auf SSL eingestellt sind.

Nächst Beispiels ein Text-Widget nur für Beiträge oder im Content eine CSS-Class oder so Shortcode einen Link bspw. zur Mediathek* beinhaltet. Welchen URL nicht korrekt vorhanden ist, so erfolgt im Browser die URL ohne das Schloss.

* Wie auch immer, solche kleine Ungereimtheiten können u. a. durch Daten Ex- und Importieren entstehen.

  • Folglich im Austausch zur korrekten URL (bspw. Bild-URL) ist das Schloss in der Adresszeile gegeben.